Enlaces de imágenes rotos en WordPress 3 multisite subdominio

broken

Si tienes WordPress 3.0 y activaste la característica multi-sitio y estás utilizando la opción subdominios (lee este artículo para saber cómo hacerlo), quizás te has encontrado con el problema de que las imágenes de tus posts están siendo subidas al servidor pero no se están mostrando. Esto se resuelve simplemente ajustando la directiva AllowOverride a All en tu archivo de configuración httpd.conf. Si no tienes acceso a dicho archivo, debes ponerte en contacto con tu proveedor

<Directory>
    Options FollowSymLinks
    AllowOverride All
</Directory>

Los que hicieron una actualización desde una versión anterior de wordpress pueden cometer el error que cometí yo. Cuando habilitas multi-sitio con la opción multi-dominio Worpress te da el siguiente código para incluirlo en el archivo .htaccess:

RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]

# uploaded files
RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^ - [L]
RewriteRule . index.php [L]

Este código debe sustituir al código anterior de WordPress que está entre #Begin WordPress y #End WordPress, no se deben agregar juntos porque provocan conflicto. Luego de horas de dolor de cabeza averiguando porqué las imágenes no se veían quité ese código viejo de .htaccess entre #Begin WordPress y #End WordPress y el problema se solucionó.

One Response
  1. febrero 23, 2012

Responder a Pere Nadal Cancelar la respuesta

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *